LISTVIEW NAO FUNCIONA

 Tópico anterior Próximo tópico Novo tópico

LISTVIEW NAO FUNCIONA

VB / VBA

 Compartilhe  Compartilhe  Compartilhe
#373885 - 13/05/2011 16:31:48

LEAO10
BRASILIA
Cadast. em:Agosto/2009




Olá a todos VBManíacos,

Estou me deparando com algo que sempre fiz e sempre funcionou, mas agora não está... acho que estou zezando em algum detalhe, só pode...

sql = "select * from Vendas where Comprador = " & ID & ""    'numeral
Set RsTemp = Arq.OpenRecordset(sql)

'****************************************************************************
    If Not RsTemp.RecordCount = 0 Then
                RsTemp.MoveFirst

                Do Until RsTemp.EOF
                Set lv = List1.ListItems.Add()
                    lv.Tag = RsTemp!Comprador
                    lv.Text = RsTemp!Comprador & ""
                    
                    lv.SubItems(1) = RsTemp!Data: MsgBox RsTemp!Data
                    
                    ItemCodVeiculo = RsTemp!CodVeiculo ': MsgBox ItemCodVeiculo
                    DadoDoVeiculo 'Puxa o nome do veiculo e a placa
                    
                    lv.SubItems(2) = NomeVeiculo & "": MsgBox NomeVeiculo
                    
                    lv.SubItems(3) = NomePlaca & "": MsgBox NomePlaca
                RsTemp.MoveNext
                Loop
                RsTemp.MoveFirst
    End If

End Sub

Coloquei um msgbox para ver se está setando a os dados, e aparece no msgbox o nome do veiculo e a placa, mas o grid do list view não aparece nada

Desde já agradeço...

Todos respiramos o mesmo ar, portanto devemos ter todos a mesma chance (Ayrton Senna)

#373886 - 13/05/2011 17:01:54

LEAO10
BRASILIA
Cadast. em:Agosto/2009


É o que dar copiar e colar sem olhar o nome...

o objeto listview estava com outro nome...

Todos respiramos o mesmo ar, portanto devemos ter todos a mesma chance (Ayrton Senna)

 Tópico anterior Próximo tópico Novo tópico


Tópico encerrado, respostas não sao permitidas
Encerrado por LEAO10 em 13/05/2011 17:02:15