CT-E 3.0 - FALHA NO SCHEMA

 Tópico anterior Próximo tópico Novo tópico

CT-E 3.0 - FALHA NO SCHEMA

C#

 Compartilhe  Compartilhe  Compartilhe
#478367 - 11/12/2017 00:11:56

DS2T
BARRA MANSA
Cadast. em:Novembro/2010


 Anexos estao visíveis somente para usuários registrados

Boa noite!

Estou tendo dificuldades para emitir a CT-e 3.0.  Está dando o erro 215 - Falha no schema.

O problema todo é que baixei os .xsd da receita para confrontar com o xml e está tudo OK.

Quando valido pelo site:  https://www.sefaz.rs.gov.br/cte/cte-val.aspx

Fica tudo ok também.

Não sei mais o que pode ser.

Alguém poderia tentar me ajudar?

Segue o xml anexo.
Vocês verão que apenas a assinatura não está batendo, mas é porque alterei alguns valores na nota depois que ela foi assinada. (Testei com ela assinada e sem modificação, colocar no validador, e está tudo OK também).

Muito obrigado!


"Cansei de frases intelectuais" - Eu mesmo


#478368 - 11/12/2017 02:21:41

JOAOBENEVIDES
RIBEIRAO PRETO
Cadast. em:Maio/2009


validando seu xml esta este resultado

PARSER XML:    OK
TIPO DE MENSAGEM:    Envio CT-e
SCHEMA:    OK
ASSINATURA XML:    Assinatura ***INVÁLIDA***

da uma olhada no metodo de assinatura

........Todos Podemos Ajudar Um ao Outro ajude vc tambem.....


#478369 - 11/12/2017 04:55:49

DS2T
BARRA MANSA
Cadast. em:Novembro/2010


Oi, boa noite!

Obrigado pela resposta.
Mas como eu disse anteriormente:

Citação:
Vocês verão que apenas a assinatura não está batendo, mas é porque alterei alguns valores na nota depois que ela foi assinada. (Testei com ela assinada e sem modificação, colocar no validador, e está tudo OK também).


Valeu!

"Cansei de frases intelectuais" - Eu mesmo


#478372 - 11/12/2017 08:38:32

KERPLUNK
RIO GRANDE DO SUL
Cadast. em:Junho/2009


Membro da equipe
Se você alterou algum valor, você vai precisar assinar de novo.

_______________________________________________________________________
Gostaria de ter seu sistema Desktop "traduzido" para uma interface web? Podemos conversar...
Virei Oráculo!
The end is nigh, be ready for the nukes!


Resposta escolhida #478373 - 11/12/2017 09:29:00

GUIMORAES
ITAPETININGA
Cadast. em:Agosto/2009


DS2T,

Este erro é na validação ou na transmissão do CT-e?




#478374 - 11/12/2017 10:04:48

DS2T
BARRA MANSA
Cadast. em:Novembro/2010


Citação:
Se você alterou algum valor, você vai precisar assinar de novo.


Opa Kerplunk. Eu apenas alterei os valores depois que assinei, para poder postar aqui e não comprometer dados do banco de dados de produção. Quando tento enviar, ou validar na receita... ele vai sem modificação após a assinatura.
De qualquer forma, obrigado pela ajuda!


Citação:
DS2T,

Este erro é na validação ou na transmissão do CT-e?


Oi Guimoraes, tudo bem?
Esse erro está acontecendo na transmissão do CT-e. Quando tento validar pelo xsd da 3.0, não apresenta erro algum, assim como quando tento validar pelo site da receita. O schema passa. Porém, quando tento transmitir para a receita, ele me retorna um xml com falha, com a tag xMotivo = Falha no schema e código do erro 215.

Os schemas utilizados para validação são o do site:
http://www.cte.fazenda.gov.br/portal/listaConteudo.aspx?tipoConteudo=0xlG1bdBass=
(NT 2017.002) (Atualizado em 13/11/2017)

Pelo que vi, o webservice continua sendo a mesma da versão 2.0. Tirando as pequenas mudanças de layout do xml no manual, acredito que não tenha mudado mais nada... Esse xml é o que envio para o serviço.

Agradecido pela ajuda!

"Cansei de frases intelectuais" - Eu mesmo


#478375 - 11/12/2017 10:29:29

ROOLSI
ESTEIO
Cadast. em:Fevereiro/2015


Bom dia, dê uma verificada no teu xml se tem algum caracter especial, ou algum tipo de acentuação que possa ocorrer esse erro, vi algo estranho na descrição do emitente.



#478376 - 11/12/2017 10:39:43

GUIMORAES
ITAPETININGA
Cadast. em:Agosto/2009


 Anexos estao visíveis somente para usuários registrados

Citação:
:
Se você alterou algum valor, você vai precisar assinar de novo.

Opa Kerplunk. Eu apenas alterei os valores depois que assinei, para poder postar aqui e não comprometer dados do banco de dados de produção. Quando tento enviar, ou validar na receita... ele vai sem modificação após a assinatura.
De qualquer forma, obrigado pela ajuda!


DS2T,

Este erro é na validação ou na transmissão do CT-e?

Oi Guimoraes, tudo bem?
Esse erro está acontecendo na transmissão do CT-e. Quando tento validar pelo xsd da 3.0, não apresenta erro algum, assim como quando tento validar pelo site da receita. O schema passa. Porém, quando tento transmitir para a receita, ele me retorna um xml com falha, com a tag xMotivo = Falha no schema e código do erro 215.

Os schemas utilizados para validação são o do site:
http://www.cte.fazenda.gov.br/portal/listaConteudo.aspx?tipoConteudo=0xlG1bdBass=
(NT 2017.002) (Atualizado em 13/11/2017)

Pelo que vi, o webservice continua sendo a mesma da versão 2.0. Tirando as pequenas mudanças de layout do xml no manual, acredito que não tenha mudado mais nada... Esse xml é o que envio para o serviço.

Agradecido pela ajuda!


Analisei seu arquivo, aparentemente está normal.
Estou anexando aqui um arquivo gerado pelo meu sistema, para que você possa comparar as informações. O arquivo não está assinado, mas é o que utilizo em vários clientes, com sucesso nas transmissões.





#478414 - 13/12/2017 12:40:33

DS2T
BARRA MANSA
Cadast. em:Novembro/2010


Oi, pessoal!

Bom dia!
Primeiramente, queria agradecer a todos pela a ajuda. Em especial ao Guimoraes que até disponibilizou o xml para eu dar uma olhada. Obrigado!

O erro foi uma desatenção da minha parte. Me foquei tanto na mudança de layout do arquivo e fiquei martelando pensando que estava no conteúdo...
Na verdade, eu esqueci de mudar o cabeçalho da mensagem de requisição do recibo. Foi falta de atenção com uma mistura de azar (pois não podia debugar o projeto, pois o certificado digital não estava comigo. Então eu testava remotamente no computador do cliente). Só fui descobrir quando tentei emitir a nota no emissor do SEBRAE e deu chave duplicada. Ou seja, a nota estava sendo emitida, mas era a consulta do recibo que estava com layout inválido (versão errada no cabeçalho).

Pessoal, novamente, muito obrigado!

"Cansei de frases intelectuais" - Eu mesmo


#478585 - 20/12/2017 19:54:36

DS2T
BARRA MANSA
Cadast. em:Novembro/2010


Estou fechando o tópico. Novamente, fico muito agradecido!




"Cansei de frases intelectuais" - Eu mesmo


 Tópico anterior Próximo tópico Novo tópico


Tópico encerrado, respostas não sao permitidas
Encerrado por DS2T em 20/12/2017 19:54:51