LOCAWEB E TRUST LEVEL FULL

 Tópico anterior Próximo tópico Novo tópico

LOCAWEB E TRUST LEVEL FULL

ASP.NET

 Compartilhe  Compartilhe  Compartilhe
#479805 - 23/02/2018 16:17:10

CLEVERTON
SERRINHA
Cadast. em:Dezembro/2003


Membro da equipe

Última edição em 23/02/2018 16:17:22 por CLEVERTON

Boa tarde, estou tentando rodar minha aplicação ASP.NET usado Entity Framework, WebAPI MVC5 na LocaWeb

Mas me parece que alguma DLL, especificamente o EF exige o <trust level="Full" />,

Citação:
A aplicação está setada para usar o nível de confiança FULL, contudo os servidores compartilhados são configurados para utilizar o TrustLevel Medium.


Será que existe solução pra isso ?




#479809 - 23/02/2018 16:32:30

KERPLUNK
RIO GRANDE DO SUL
Cadast. em:Junho/2009


Membro da equipe
Qual banco de dados está usando?

_______________________________________________________________________
Gostaria de ter seu sistema Desktop "traduzido" para uma interface web? Podemos conversar...
Virei Oráculo!
The end is nigh, be ready for the nukes!


#479810 - 23/02/2018 16:44:54

CLEVERTON
SERRINHA
Cadast. em:Dezembro/2003


Membro da equipe
SQL Server 2008 EE



#479812 - 23/02/2018 16:57:11

KERPLUNK
RIO GRANDE DO SUL
Cadast. em:Junho/2009


Membro da equipe
Tem certeza que é o EF que está exigindo Full Trust? Até onde sei ele não faz reflection e não precisa disso... Quais os componentes que está usando?

_______________________________________________________________________
Gostaria de ter seu sistema Desktop "traduzido" para uma interface web? Podemos conversar...
Virei Oráculo!
The end is nigh, be ready for the nukes!


#479813 - 23/02/2018 17:01:26

CLEVERTON
SERRINHA
Cadast. em:Dezembro/2003


Membro da equipe

 Anexos estao visíveis somente para usuários registrados

Segue na imagem.



#479816 - 23/02/2018 17:05:59

KERPLUNK
RIO GRANDE DO SUL
Cadast. em:Junho/2009


Membro da equipe
Usa DBFirst ou CodeFirst?

_______________________________________________________________________
Gostaria de ter seu sistema Desktop "traduzido" para uma interface web? Podemos conversar...
Virei Oráculo!
The end is nigh, be ready for the nukes!


#479821 - 23/02/2018 18:40:24

CLEVERTON
SERRINHA
Cadast. em:Dezembro/2003


Membro da equipe
CodeFirst



#479881 - 26/02/2018 09:14:36

KERPLUNK
RIO GRANDE DO SUL
Cadast. em:Junho/2009


Membro da equipe
Já experimentou simplesmente publicar com level medium?

_______________________________________________________________________
Gostaria de ter seu sistema Desktop "traduzido" para uma interface web? Podemos conversar...
Virei Oráculo!
The end is nigh, be ready for the nukes!


#479886 - 26/02/2018 10:19:39

CLEVERTON
SERRINHA
Cadast. em:Dezembro/2003


Membro da equipe
Sim, mas exige o FULL, como eu posso verificar as dlls que exigem o FULL ?



#479887 - 26/02/2018 10:23:28

KERPLUNK
RIO GRANDE DO SUL
Cadast. em:Junho/2009


Membro da equipe
Citação:
:
Sim, mas exige o FULL, como eu posso verificar as dlls que exigem o FULL ?

Essa é uma boa pergunta...

_______________________________________________________________________
Gostaria de ter seu sistema Desktop "traduzido" para uma interface web? Podemos conversar...
Virei Oráculo!
The end is nigh, be ready for the nukes!


#479890 - 26/02/2018 11:08:40

CLEVERTON
SERRINHA
Cadast. em:Dezembro/2003


Membro da equipe

Última edição em 26/02/2018 11:08:59 por CLEVERTON

Eu vou fazer uma cópia e ir deletando as dependências. Posto o resultado aqui.




 Tópico anterior Próximo tópico Novo tópico


Tópico encerrado, respostas não sao permitidas
Encerrado por CLEVERTON em 10/05/2018 16:01:36