BALANÇA ELGIN SA-110

 Tópico anterior Próximo tópico Novo tópico

BALANÇA ELGIN SA-110

VB.NET

 Compartilhe  Compartilhe  Compartilhe
#481095 - 21/04/2018 19:58:54

TRTNCG
CAMPINA GRANDE
Cadast. em:Fevereiro/2004


Última edição em 21/04/2018 20:24:02 por TRTNCG

Olá galera, Boa Noite!

Amigos será que aqui alguém pode me dá uma luz, bom é o seguinte um cliente comprou uma balança ELGIN SA-110, estou implementando para ela ler o peso automaticamente mno sistema, no entanto o estranho é que:

O cabo conversor USB serial RS232 que a cliente comprou, MADE IN CHINA sei lá que marca é, do programa padrão que a elgin mandou para testes ler o peso certinho, mas do meu sistema não consegue ler, ou seja sempre retorna VAZIO, já instalei os drivers, verifique em dispositivos e está tudo certinho, no entanto não consigo ler do meu sistema o peso.

Eu tinha um cabo USB SERIAL da Multilaser e fiz o teste de primeira leu, no entanto, sei lá o que foi, de uma hora para outra recebia os dados semprfe com PONTO FINAL exemplo: 0.601, 0.254, do nada ela não está mais retornando com o PONTO FINAL

e sim 0701, para 0,701 gramas, 0254 para 245 o que está acontecendo alguém já trabalhou com esta balança

Teria que formatar assim 0,235, 0,124, 1,245 alguém me dá uma dica?





#481113 - 23/04/2018 14:02:06

FERDEAD
LIMEIRA
Cadast. em:Outubro/2004


pega o valor que ela retornou e divide por 1000.. vai cair na máscara que você precisa!




Resposta escolhida #481128 - 23/04/2018 16:55:22

MFLAVIO
CAMPINAS
Cadast. em:Maio/2009


Citação:
:
Olá galera, Boa Noite!

Amigos será que aqui alguém pode me dá uma luz, bom é o seguinte um cliente comprou uma balança ELGIN SA-110, estou implementando para ela ler o peso automaticamente mno sistema, no entanto o estranho é que:

O cabo conversor USB serial RS232 que a cliente comprou, MADE IN CHINA sei lá que marca é, do programa padrão que a elgin mandou para testes ler o peso certinho, mas do meu sistema não consegue ler, ou seja sempre retorna VAZIO, já instalei os drivers, verifique em dispositivos e está tudo certinho, no entanto não consigo ler do meu sistema o peso.

Eu tinha um cabo USB SERIAL da Multilaser e fiz o teste de primeira leu, no entanto, sei lá o que foi, de uma hora para outra recebia os dados semprfe com PONTO FINAL exemplo: 0.601, 0.254, do nada ela não está mais retornando com o PONTO FINAL

e sim 0701, para 0,701 gramas, 0254 para 245 o que está acontecendo alguém já trabalhou com esta balança

Teria que formatar assim 0,235, 0,124, 1,245 alguém me dá uma dica?


ja passei por isso, lembro que foi só substituir o Drive do Cabo Conversor, tinha um drive que ja entregava o valor Formatado para KiloGramas, e ai formatou o PC o técnico, instalou um driver que retornava um padrão txt (0,250 KG) retornava 000250 então precisei mudar o tratamento de retorno. e Formatar o Valor conforme minha necessidade  

Deus e o maior dos Programadores, ele criou tudo em liguagem visual
                                           .... e viu Deus que era bom


 Tópico anterior Próximo tópico Novo tópico


Tópico encerrado, respostas não sao permitidas
Encerrado por TRTNCG em 17/10/2018 16:10:54