FALHA AO INICIAR O ADAPTADOR DE DEPURAO.

 Tópico anterior Próximo tópico Novo tópico

FALHA AO INICIAR O ADAPTADOR DE DEPURAO.

ASP.NET

 Compartilhe  Compartilhe  Compartilhe
#491325 - 19/11/2019 10:08:12

PERCIFILHO
MATAO [SP]
Cadast. em:Dezembro/2009


Bom dia a todos!
Criei uma WebApi e estava testando, consumindo, tudo certinho. S que de repente, de uma hora pra outra, no sei o que aconteceu, quando vou rodar a WebApi no IIS, aparece uma mensagem:

Um ou mais erros.
Falha ao iniciar o adaptador de depurao. Informaes adicionais podem estar disponveis na janela de sada.
Cannot connect to runtime process, timeout after 10000 ms (reason: Cannot connect to the target: connect ECONNREFUSED 127.0.0.1:50777).


Agora, j criei uma outra WebApi e no consigo mais rodar, aparece sempre o mesmo erro. O que ser que eu fiz de errado?
Procurei na net mas ainda no consegui uma soluo;
Algum j passou por isso? Ser que vou ter que instalar novamente o Visual Studio? Ou isso seria um problema de configurao do IIS?
Ou configurao do projeto?
Utilizo o Visual Studio 2019;
Se algum puder me ajudar, agradeo muito;

____________________________________________________
No h nessa vida algo que no se possa alcanar, voc s precisa ir buscar.

#491326 - 19/11/2019 10:10:40

PERCIFILHO
MATAO [SP]
Cadast. em:Dezembro/2009


Ah, esqueci de dizer: como est escrito na mensagem que mais informaes poder estar disponveis na janela de sada, l est assim:

Verbose logs are written to:
C:\Users\perci\AppData\Local\Temp\vscode-chrome-debug.txt
O programa [][] foi fechado com o cdigo -1 (0xffffffff).
O programa [][8904] iisexpress.exe[] foi fechado com o cdigo 0 (0x0).



____________________________________________________
No h nessa vida algo que no se possa alcanar, voc s precisa ir buscar.

#491571 - 27/11/2019 14:47:31

PERCIFILHO
MATAO [SP]
Cadast. em:Dezembro/2009


Última edição em 27/11/2019 14:49:03 por PERCIFILHO

Bom, pessoal, segui um tutorial que encontrei na net e apaguei o contedo da pasta:
Arquivos de programas(x86)/Common files/Microsoft Shared/VS7Debug
e consegui finalmente rodar a web api, porm o iis alterou a porta de 50201 para 44342.
Agora, minha aplicao Web no consegue retornar os dados da api, mesmo eu trocando a porta no BaseAddress.
Como fao para reparar esse erro?
Ocorre o erro:
System.Threading.Tasks.TaskCanceledException: []Uma tarefa foi cancelada.[]
e o BaseAddress aparece null.


____________________________________________________
No h nessa vida algo que no se possa alcanar, voc s precisa ir buscar.

#491572 - 27/11/2019 14:59:14

PERCIFILHO
MATAO [SP]
Cadast. em:Dezembro/2009


Desculpe, pessoal, foi um erro []grotesco[] meu, ao invs de colocar o []https://[] eu me esqueci do []s[], colocando apenas []http://[]
Agora funcionou.

____________________________________________________
No h nessa vida algo que no se possa alcanar, voc s precisa ir buscar.

 Tópico anterior Próximo tópico Novo tópico


Tópico encerrado, respostas não sao permitidas
Encerrado por PERCIFILHO em 28/11/2019 13:43:07