PROBLEMA IDE VB6

RICARDOWEB084 21/02/2024 11:06:22
#503091
Voltei a utilizar um sistema feito em vb6 este ano.
Instalei o vb6 professional edition, o SP6 e mais três atualizações, a VB60SP6-KB2708437, VB60SP6-KB3096896 e a VisualBasic6-KB896559

O problema que estou tendo nucna aconteceu antes.
Não consigo mais mexer o cursor do depurador de códigos, aquele em amarelo. (imagem anexada)

Isso dificulta muito a manutenção e os testes.

Alguém tem ideia do que pode ser este erro?
EPISCOPAL 21/02/2024 22:24:32
#503094
Alterado em 21/02/2024 22:26:11 Estranho ..... qual win está usando? Eu apostaria em uma nova instalação ..... somente a vb60sp6-kb3096896-x86-enu.msi deveria ser instalada, esta é a ultima e substitui as outras.

visualbasic6-kb896559-v1-enu.exe eu nunca usei ...
RICARDOWEB084 22/02/2024 09:45:43
#503095
Alterado em 22/02/2024 10:22:01 Já refiz a instalação umas 3 vezes, sem sucesso. Estou usando o Windows 10 64bits.

Limpei até os registros do Windows e fui fazendo a reinstalação testando o recurso em cada etapa, antes da instalação das atualizações.
Continua sem funcionar, nunca tinha visto isso.

Estou me virando da seguinte forma agora
? seleciono a linha direto no editor, não na barra lateral, e pressiono Ctrl + F9, o cursor amarelo é direcionado para ela.
Mas pegar e arrastar a seta amarela com o mouse, simplesmente parou de funcionar de uma hora para outra, prejudica bastante a produtividade.
EPISCOPAL 22/02/2024 13:13:32
#503096
Infelizmente o IDE do VB6 não tem mais suporte. Estou no Win11_64 e está tudo ok.
LEAO10 26/02/2024 20:52:34
#503112
Eu prefiro uma forma de depuração mais manual... vou colocando MSGBOX em várias partes... algo como msgbox "1", msgbox "2" ... geralmente descubro o problema rapidamente
WEBMASTER 27/02/2024 08:55:34
#503113
debug.print

Não ajuda ???
De fato vai ser dificil resolver hoje esse tipo de conflito/problema
RICARDOWEB084 27/02/2024 19:43:44
#503126
Alterado em 27/02/2024 22:11:45 Talvez eu não tenha explicado tão bem, um vídeo mostraria o problema melhor.
Aquela seta amarela que aparece na lateral, conforme a foto que coloquei, é útil quando voce altera o código durante a depuração do projeto e quer retomar a rotina desde o início para executar o código pós-alterações.
O usuário pressiona o mouse sobre ela e a arrasta para cima, ou para baixo, até o ponto desejado e reinicia a depuração.

É justamente este arrastar a seta amarela que não funciona, o IDE aciona o "ponto de parada", o círculo roxo, ao invés de permitir selecioná-la.
Isso aconteceu de um segundo para outro, estava funcionando durante a depuração e nunca mais funcionou.

De qualquer forma, contornei isso com o atalho no teclado CTRL + F9.
Ainda não descobri a causa do problema.
Faça seu login para responder